const regex = /[\d\/-]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d\\\/-]+', 'g')
const str = `Estou tentando montar uma expressão regular e não estou conseguindo.
Como faço para montar uma expressão re34gular que aceite apenas nú-meros, bar21ra e hí/fen?
Mas opde ser essa possibilidade 2345/-tbm?
Ou /-234opde ser essa possibilidade 2345/-tbm?
Se vc apagar o modificador g verá uma diferença.
1234/-
-/1234y
/-k2565
/345663-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}