import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Za-z0-9+\\/]{4})*(?:[A-Za-z0-9+\\/]{4}|[A-Za-z0-9+\\/]{3}=|[A-Za-z0-9+\\/]{2}={2})$";
final String string = "ThisIsNotBase64Because/ItIsNotMod4\n"
+ "ThisIsBase64Because/ItIsMod4\n"
+ "ThisIsAlso/Base64+EvenWithPadding+==\n"
+ "ThisIsNotBase64+Because-ThereIsADash\n"
+ "YouGetTheIdea/==";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}