$re = '/^(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2})$/m';
$str = 'ThisIsNotBase64Because/ItIsNotMod4
ThisIsBase64Because/ItIsMod4
ThisIsAlso/Base64+EvenWithPadding+==
ThisIsNotBase64+Because-ThereIsADash
YouGetTheIdea/==';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);