// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2})$").unwrap();
let string = "ThisIsNotBase64Because/ItIsNotMod4
ThisIsBase64Because/ItIsMod4
ThisIsAlso/Base64+EvenWithPadding+==
ThisIsNotBase64+Because-ThereIsADash
YouGetTheIdea/==";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}