$re = '/{[^{]*/ms';
$str = '{ABC}
+ 1
- 1
{DEF}
+ 2
- 2
{IJK}
+ 3
- 3
{LMN}
+ 4
- 4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);