import re
regex = re.compile(r".*", flags=re.DOTALL)
test_str = ("$t = @(\n"
" @(30, 29, 30, 29, 41),\n"
" @(1, 1, 25, 30, 25, 30, 25, 25, 25, 25, 25, 25, 25, 25, 40, 1, 1),\n"
" @(31, 34, 34, 20, 34, 28, 28, 23, 27, 31, 33, 34, 29, 24, 33, 32, 21, 34, 30, 21, 29, 22, 31, 23, 26, 32, 29, 32, 24, 27),\n"
" @(26, 29, 22, 22, 31, 31, 27, 28, 32, 23, 33, 25, 31, 33, 34, 30, 23, 26, 21, 28, 32, 22, 30, 34, 26, 33, 20, 27, 33),\n"
" @(20, 31, 20, 29, 29, 33, 34, 33, 20),\n"
" @(25, 26, 34, 34, 41, 28, 32, 30, 34, 23, 26, 33, 30, 22, 30, 33, 24, 20, 27, 23, 30, 23, 34, 20, 23, 20, 33, 20, 28),\n"
" @(34, 23, 31, 34, 34, 30, 29, 31, 29, 21, 25, 31, 30, 29, 29, 28, 21, 29, 33, 25, 24, 30),\n"
" @(22, 31, 23, 23, 26, 21, 22, 20, 20, 28, 24, 28, 25, 31, 31, 26, 33, 31, 27, 29, 30, 30),\n"
" @(26, 29, 25, 30, 32, 28, 26, 26, 33, 20, 21, 32, 28, 28, 20, 34, 34),\n"
" @(34, 33, 29, 26, 34, 32, 27, 26, 22),\n"
" @(30, 31, 23, 21, 30, 27, 32, 30, 34, 29, 21, 31, 31, 31, 32, 27, 30, 26, 21, 34, 29, 33, 24, 24, 32, 27, 32),\n"
" @(25, 33, 33, 25, 24, 27, 34, 31, 29, 31, 27, 23)\n"
")\n\n"
"$f = @(\n"
" @(30),\n"
" @(31, 29, 29, 28, 24, 23, 29, 29, 26, 27, 33, 20, 26, 26, 20, 30),\n"
" @(29, 29, 29, 47, 30),\n"
" @(23, 31, 29, 26, 30, 24, 29, 29, 25, 27, 24, 28, 22, 20, 34, 22, 32, 24, 33),\n"
" @(23, 24, 25, 20, 24, 34, 28, 32, 22, 20, 24),\n"
" @(24, 28, 21, 34, 34, 25, 24, 33, 23, 20, 32, 26, 29, 29, 25, 20, 30, 24, 23, 21, 27),\n"
" @(26, 34, 21, 32, 32, 30, 32, 21, 34, 21, 34, 31, 23, 27, 26, 32),\n"
" @(29, 24, 22, 27, 22, 25, 29, 26, 24, 24, 20, 25, 20, 20, 24, 20),\n"
" @(23, 33, 22, 32, 30),\n"
" @(28, 21, 22, 33, 22, 26, 30, 28, 26, 23, 31, 22, 31, 25, 27, 27, 25, 28),\n"
" @(27, 23, 42, 23, 22, 28),\n"
" @(25, 20, 30, 29, 32, 25, 22, 21, 31, 22, 23, 25, 22, 31, 23, 25, 33, 23)\n"
")\n\n"
"\"Should be $true\"\n"
"$t | % {\n"
" [bool](.\\get-heatWave.ps1 @_)\n"
"}\n\n"
"\"Should be $false\"\n"
"$f | % {\n"
" [bool](.\\get-heatWave.ps1 @_)\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")