package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:[a-zA-Z0-9_.+-/#~]+ `)
var str = `眼影盤長這樣 http://i.imgur.com/uxvRo3h.jpg 說真的 很不好拍`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}