re = /id=(.+)&/
str = 'https://play.google.com/store/apps/details?id=com.alibaba.aliexpresshd&hl=en'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end