import Foundation
let pattern = #"([^\v\t]+)\s*([^\v\t]+)\s*([^\v\t]+)([\v\t]+|Loading transaction details for|[\v\t]+\1){0,3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Google
- negative$4.99
Jun 21Automatic Payment
Google
- negative$4.99
Jun 21Automatic Payment
Loading transaction details for
Google
- negative$4.99
Jun 21Automatic Payment
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)