$re = '/^(?!.*(11|22|33|44|55|66|77|88|99|01|12|23|34|45|56|67|78|89|10|21|32|43|54|65|76|87|98))\d{4}$/m';
$str = '1111
5555
1234
7564
1148
1559
1499
1268
1569
1389
9851
9651
9532
1579
8264
1359
9461
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);