const regex = /T2G5P6/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('T2G5P6', '')
const str = `Stephen Avenue 700 Center St SE Calgary, AB T2G5P6 Hyatt Regency Website Facebook `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}