import Foundation
let pattern = #"T2G5P6"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Stephen Avenue 700 Center St SE Calgary, AB T2G5P6 Hyatt Regency Website Facebook "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}