using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((s)|(svc))((-)|(_)).+)|((.+)((-)|(_))(svc))|(((.+)(svc))|((svc)(.+)))";
string input = @"s-sumnamessvc
s_somenames
s-somenameapp
s_somesvc
svc-wookir2d2
svc_wookic3p0
hansoloapp_svc
hansolomillenium-svc
sqldbsvc
svcappofsomesort
_somesvc
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}