import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((s)|(svc))((-)|(_)).+)|((.+)((-)|(_))(svc))|(((.+)(svc))|((svc)(.+)))";
final String string = "s-sumnamessvc\n"
+ "s_somenames\n"
+ "s-somenameapp\n"
+ "s_somesvc\n"
+ "svc-wookir2d2\n"
+ "svc_wookic3p0\n"
+ "hansoloapp_svc\n"
+ "hansolomillenium-svc\n"
+ "sqldbsvc\n"
+ "svcappofsomesort\n"
+ "_somesvc\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}