$re = '/(((s)|(svc))((-)|(_)).+)|((.+)((-)|(_))(svc))|(((.+)(svc))|((svc)(.+)))/i';
$str = 's-sumnamessvc
s_somenames
s-somenameapp
s_somesvc
svc-wookir2d2
svc_wookic3p0
hansoloapp_svc
hansolomillenium-svc
sqldbsvc
svcappofsomesort
_somesvc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);