Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(((s)|(svc))((-)|(_)).+)|((.+)((-)|(_))(svc))|(((.+)(svc))|((svc)(.+)))
"
gi
Input 1
1
New
s-sumnamessvc s_somenames s-somenameapp s_somesvc svc-wookir2d2 svc_wookic3p0 hansoloapp_svc hansolomillenium-svc sqldbsvc svcappofsomesort _somesvc