^start of string
Negated Character Class[^\-]* *matches any number of characters outside the set below:
\-the literal - (4510 / 558 / 2D16)
\Wany character that is not a Unicode word character
Negated Character Class[^\s]* *matches any number of characters outside the set below:
\sa Unicode whitespace character
\s+a Unicode whitespace character, repeated at least once
Negated Character Class[^\s]* *matches any number of characters outside the set below:
\sa Unicode whitespace character
\s+a Unicode whitespace character, repeated at least once
Negated Character Class[^\s]* *matches any number of characters outside the set below:
\sa Unicode whitespace character
\s+a Unicode whitespace character, repeated at least once
Negated Character Class[^\s]* *matches any number of characters outside the set below:
\sa Unicode whitespace character
\s+a Unicode whitespace character, repeated at least once
.*any Unicode character (except for line terminators), repeated any number of times
$end of string, or before its final line terminator