#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*\K<!--.*?stylesheet.*?-->"
Local $sString = "<!-- The quick brown fox " & @CRLF & _
" jumps over the lazy dog -->" & @CRLF & _
"" & @CRLF & _
"<!--[if IE 7]>" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="/supersheet.css" />" & @CRLF & _
"<![endif]-->" & @CRLF & _
"" & @CRLF & _
"<!-- Pack my box with five dozen liquor jugs -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")