$re = '/(?xm)^
(?:
[^;"\'\']+
(?:
(?:\'[^\'\']*\')|
(?:"[^"]*")
)*
)*+
(;\N+)/mx';
$str = '$x = "a" & "b" ; com
; test
; "test"
; "test\'
; \'test\'
; \'test"
$x=\'\' ; chaîne "vide"
$x="" ; chaîne "vide"
$x="" ; chaîne \'vide\'
$x = "aa;aa" ; Comment-line
$x = "a" ;$x=\'b\'
$x=\' \'\' \'\';\'\' ";" "\'\' \'\'" "\'\'"\' ; chaîne "vide"
$x=\' \'\' \'\';\'\' ";" "\'\' \'\'" "\'\'"\' ; chaîne \'vide\'
$x=" \' \';\' "";"" ""\' \'"" ""\'""" ; chaîne "vide"
$x=" \' \';\' "";"" ""\' \'"" ""\'""" ; chaîne \'vide\'
$x = \'bb;b\'
$x = "bb;b"
$x = " " & "bb"
;;;;
; ; ;";\'
; test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);