re = /^(\d{12})([A-HK-MRT-Y]{1})$/m
str = '123123123123H
456456456778L
123123123123H'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end