$re = '/e(?=\s|$|[\.!\'"\-:;\?\(\)])/';
$str = 'Some text to show this is matching words ending with "e". Bee-Bee: Bee! Bee? Bee; Bee
Bee\\Bee/Bee and (Bee) but bee@bee.bee';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);