$re = '/(?=([A-Z]\d[A-Z]\s*\d[A-Z]\d))/m';
$str = 'SOMETEXTJ9H5G0L2J0OTHERSTUFF
SOMETEXTA0A 0A0OTHERSTUFF
SOMETEXTB1A0A0A0OTHERSTUFFB2A B2BOTHER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);