#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\([^|)]+\|[^)]+\) *\+ ?| \+? *\([^|)]+\|[^)]+\)"
Local $sString = "y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g" & @CRLF & _
"y~1+a+(b|c)+(d^2)+e+ (1|f)+g" & @CRLF & _
"(b | c) + y ~ 1 + a + (d^2) + e + (1 | f) + g" & @CRLF & _
"y ~ 1 + a + (d^2) + e + (1 | f) + g + (b | c) " & @CRLF & _
"(h|i) + y ~ 1 + a + (b | c) + (d^2) + e + (1 | f) + g +(j+k| m)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)