$re = '/(\*\*?)(?![\s\*])((?:[\s*]*(?:\\\\[\\\\*]|[^\\\\\s*]))+?)\1/s';
$str = '**fi*rst b** some normal text here **second b** *first i* normal *second i* normal aggain';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);