// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w]+\@[\w]+\.[^\d\W]+").unwrap();
let string = "a@a.a
1@a.a
a@1.a
a@a.1
aa@aa.aa
1a@aa.aa
aa@1a.aa
aa@aa.1a
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}