const regex = /^\D*(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\D*(\\d)', 'gm')
const str = `This is a string 1.
This is 1 a string.
This is1 a string.
1This is a string.
1 This is a string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}