re = /^\D*(\d)/m
str = 'This is a string 1.
This is 1 a string.
This is1 a string.
1This is a string.
1 This is a string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end