import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([12]\\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\\d|3[01]) ([01][0-9]|2[0-3]):[0-5]\\d)";
final String string = "minute/second\n"
+ "2105-12-21 00:00\n"
+ "2105-12-21 00:60\n"
+ "2105-12-21 23:00\n"
+ "2105-12-21 24:00\n"
+ "2105-12-21 23:59\n\n"
+ "year/month/day\n"
+ "2105-00-00 11:01\n"
+ "2105-00-01 11:01\n"
+ "2105-01-00 11:01\n"
+ "2105-01-01 11:01\n"
+ "2105-01-12 11:01\n"
+ "2105-01-13 11:01\n"
+ "2105-01-20 11:01\n"
+ "2105-01-29 11:01\n"
+ "2105-01-30 11:01\n"
+ "2105-01-31 11:01\n"
+ "2105-01-32 11:01\n"
+ "2105-00-31 11:01\n"
+ "2105-01-31 11:01\n"
+ "2105-09-31 11:01\n"
+ "2105-10-31 11:01\n"
+ "2105-12-31 11:01\n"
+ "2105-13-31 11:01\n"
+ "2016-01-01 11:11\n"
+ "3016-01-01 11:11\n"
+ "1016-01-01 11:11\n"
+ "0016-01-01 11:11";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}