use strict;
my $str = 'minute/second
2105-12-21 00:00
2105-12-21 00:60
2105-12-21 23:00
2105-12-21 24:00
2105-12-21 23:59
year/month/day
2105-00-00 11:01
2105-00-01 11:01
2105-01-00 11:01
2105-01-01 11:01
2105-01-12 11:01
2105-01-13 11:01
2105-01-20 11:01
2105-01-29 11:01
2105-01-30 11:01
2105-01-31 11:01
2105-01-32 11:01
2105-00-31 11:01
2105-01-31 11:01
2105-09-31 11:01
2105-10-31 11:01
2105-12-31 11:01
2105-13-31 11:01
2016-01-01 11:11
3016-01-01 11:11
1016-01-01 11:11
0016-01-01 11:11';
my $regex = qr/([12]\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01]) ([01][0-9]|2[0-3]):[0-5]\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}