#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)THttpServer:\W*(\w+)"
Local $sString = "23:25:04.805: INFO: THttpServer: transportTCPChanged(state: DISCONNECTED 2)" & @CRLF & _
"23:25:13.120: INFO: THttpServer: transportUDPOpened(state: Port 54)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")