import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "THttpServer:\\W*(\\w+)";
final String string = "23:25:04.805: INFO: THttpServer: transportTCPChanged(state: DISCONNECTED 2)\n"
+ "23:25:13.120: INFO: THttpServer: transportUDPOpened(state: Port 54)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}