use strict;
my $str = 'adsdasd.sdfdsfsdf.f43fvev.ASCSDF.sfgsdfssdf.yaml';
my $regex = qr/(?!\.[^.]*$)\./mp;
my $subst = '/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";