using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<%.*?%>";
string input = @"BLA BLA text text <%eval request(""BLA"")%> text text <%eval request(""BLA"")%> text BLA";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}