$re = '/^(?<localpart>[^-].*[^-])@(?<domainpart>[^-].*[^-])\..{2,3}$/m';
$str = 'local__part@domain_part.com
-local__part@-domain_part.com
-local__part@domain_part-.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);