#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\(\)\n[[:space:]]{1,}\{)|(\(\)[[:space:]]{1,}\{)"
Local $sString = "// feedback thread" & @CRLF & _
"" & @CRLF & _
"import java.util.*;" & @CRLF & _
"" & @CRLF & _
"class Main" & @CRLF & _
"{" & @CRLF & _
" static Scanner scan = new Scanner(System.in);" & @CRLF & _
" static String deadEnd = "dead end--morphing backwards!";" & @CRLF & _
" static String gettingCloser = "You'r getting closer";" & @CRLF & _
" " & @CRLF & _
" // call this method after each decision has been made" & @CRLF & _
" public static void clearScreen() {" & @CRLF & _
" Scanner scan = new Scanner(System.in);" & @CRLF & _
" System.out.println("Press enter to continue.");" & @CRLF & _
" String x = scan.nextLine(); " & @CRLF & _
" System.out.print("\033[H\033[2J"); " & @CRLF & _
" System.out.flush(); " & @CRLF & _
" } " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" public static void decisionZero()" & @CRLF & _
" {" & @CRLF & _
" System.out.println("Decision Point 0");" & @CRLF & _
" System.out.println("Choose a direction Mr. Mouse");" & @CRLF & _
" String direction = scan.nextLine();" & @CRLF & _
" switch (direction.toLowerCase()) {" & @CRLF & _
" case "n":" & @CRLF & _
" System.out.println("You chose north.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" decisionZero();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "s":" & @CRLF & _
" System.out.println("You chose south.");" & @CRLF & _
" System.out.println(gettingCloser);" & @CRLF & _
" decisionOne();" & @CRLF & _
" break;" & @CRLF & _
" " & @CRLF & _
" case "e":" & @CRLF & _
" System.out.println("You chose east.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" decisionZero();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "w":" & @CRLF & _
" System.out.println("You chose west.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" decisionZero();" & @CRLF & _
" break;" & @CRLF & _
" " & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" public static void decisionOne()" & @CRLF & _
" {" & @CRLF & _
" System.out.println("Decision Point 1");" & @CRLF & _
" System.out.println("Choose a direction Mr. Mouse");" & @CRLF & _
" String direction = scan.nextLine();" & @CRLF & _
" switch (direction.toLowerCase()) {" & @CRLF & _
" case "n":" & @CRLF & _
" System.out.println("You chose north.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" decisionZero();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "s":" & @CRLF & _
" System.out.println("You chose south.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" decisionZero();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "e":" & @CRLF & _
" System.out.println("You chose east.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" decisionZero();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "w":" & @CRLF & _
" System.out.println("You chose west.");" & @CRLF & _
" System.out.println(gettingCloser);" & @CRLF & _
" decisionTwo();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" public static void decisionTwo()" & @CRLF & _
" {" & @CRLF & _
" System.out.println("Decision Point 2");" & @CRLF & _
" System.out.println("Choose a direction Mr. Mouse");" & @CRLF & _
" String direction = scan.nextLine();" & @CRLF & _
" int rndDecion = (int)(Math.random()*2);" & @CRLF & _
" switch (direction.toLowerCase()) {" & @CRLF & _
" case "n":" & @CRLF & _
" System.out.println("You chose north.");" & @CRLF & _
" System.out.println(gettingCloser);" & @CRLF & _
" decisionThree();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "s":" & @CRLF & _
" System.out.println("You chose south.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "e":" & @CRLF & _
" System.out.println("You chose east.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "w":" & @CRLF & _
" System.out.println("You chose west.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" public static void decisionThree()" & @CRLF & _
" {" & @CRLF & _
" System.out.println("Decision Point 3");" & @CRLF & _
" System.out.println("Choose a direction Mr. Mouse");" & @CRLF & _
" String direction = scan.nextLine();" & @CRLF & _
" int rndDecion = (int)(Math.random()*3);" & @CRLF & _
" switch (direction.toLowerCase()) {" & @CRLF & _
" case "n":" & @CRLF & _
" System.out.println("You chose north.");" & @CRLF & _
" System.out.println(gettingCloser);" & @CRLF & _
" decisionFour();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "s":" & @CRLF & _
" System.out.println("You chose south.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "e":" & @CRLF & _
" System.out.println("You chose east.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "w":" & @CRLF & _
" System.out.println("You chose west.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" public static void decisionFour()" & @CRLF & _
" {" & @CRLF & _
" System.out.println("Decision Point 4");" & @CRLF & _
" System.out.println("Choose a direction Mr. Mouse");" & @CRLF & _
" String direction = scan.nextLine();" & @CRLF & _
" int rndDecion = (int)(Math.random()*4);" & @CRLF & _
" switch (direction.toLowerCase()) {" & @CRLF & _
" case "n":" & @CRLF & _
" System.out.println("You chose north.");" & @CRLF & _
" System.out.println(gettingCloser);" & @CRLF & _
" decisionFive();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "s":" & @CRLF & _
" System.out.println("You chose south.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "e":" & @CRLF & _
" System.out.println("You chose east.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "w":" & @CRLF & _
" System.out.println("You chose west.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" public static void decisionFive()" & @CRLF & _
" {" & @CRLF & _
" System.out.println("Decision Point 5");" & @CRLF & _
" System.out.println("Choose a direction Mr. Mouse");" & @CRLF & _
" String direction = scan.nextLine();" & @CRLF & _
" int rndDecion = (int)(Math.random()*5);" & @CRLF & _
" switch (direction.toLowerCase()) {" & @CRLF & _
" case "n":" & @CRLF & _
" System.out.println("You chose north.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" case 4:" & @CRLF & _
" decisionFour();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "s":" & @CRLF & _
" System.out.println("You chose south.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" case 4:" & @CRLF & _
" decisionFour();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "e":" & @CRLF & _
" System.out.println("You chose east.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" case 4:" & @CRLF & _
" decisionFour();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "w":" & @CRLF & _
" System.out.println("You chose west.");" & @CRLF & _
" System.out.println(gettingCloser);" & @CRLF & _
" decisionSix();" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" public static void decisionSix()" & @CRLF & _
" {" & @CRLF & _
" System.out.println("Decision Point 6");" & @CRLF & _
" System.out.println("Choose a direction Mr. Mouse");" & @CRLF & _
" String direction = scan.nextLine();" & @CRLF & _
" int rndDecion = (int)(Math.random()*5);" & @CRLF & _
" switch (direction.toLowerCase()) {" & @CRLF & _
" case "n":" & @CRLF & _
" System.out.println("You chose north.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" case 4:" & @CRLF & _
" decisionFour();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "s":" & @CRLF & _
" System.out.println("You chose south.");" & @CRLF & _
" System.out.println(deadEnd);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" case 4:" & @CRLF & _
" decisionFour();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "e":" & @CRLF & _
" System.out.println("You chose east.");" & @CRLF & _
" System.out.println("Victory cheese!");" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case "w":" & @CRLF & _
" System.out.println("You chose west.");" & @CRLF & _
" System.out.println(gettingCloser);" & @CRLF & _
" switch (rndDecion) {" & @CRLF & _
" case 0:" & @CRLF & _
" decisionZero();" & @CRLF & _
" case 1:" & @CRLF & _
" decisionOne();" & @CRLF & _
" case 2:" & @CRLF & _
" decisionTwo();" & @CRLF & _
" case 3:" & @CRLF & _
" decisionThree();" & @CRLF & _
" case 4:" & @CRLF & _
" decisionFour();" & @CRLF & _
" }" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" // the main method is COMPLETE. Add/change nothing here." & @CRLF & _
" public static void main(String[] args) " & @CRLF & _
" {" & @CRLF & _
" decisionZero(); //only line in main method." & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"}"
Local $sSubst = "()\n {\n clearScreen();"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)