$re = '/\[[^][]*[^][\d][^][]*]/m';
$str = 'Tag1[aA], Tag2[55].AA[*], Tag3[A1];';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);