package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)--?\b\d+\b`)
var str = `Check number -12 13 -13 14 -14 15 -15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}