const regex = /\bERROR:\h.*|\bOK:\hALL\hOK(?=\h+\([^()]*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bERROR:\\h.*|\\bOK:\\hALL\\hOK(?=\\h+\\([^()]*\\))', 'gm')
const str = `OK: ALL OK (8536972.66889)
ERROR: ioerror/8536615.22927
OK: ALL OK (8546369.92291)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}