$re = '/\bERROR:\h.*|\bOK:\hALL\hOK(?=\h+\([^()]*\))/m';
$str = 'OK: ALL OK (8536972.66889)
ERROR: ioerror/8536615.22927
OK: ALL OK (8546369.92291)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);