package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https\:\/\/\S+?\.domain.ru$`)
var str = `https://login1.domain.ru
https://login2.domain.ru
https://login3.domain.ru
https://login4.domain.ru
https://login4.domain1.ru
https://123.domain.ru
https://login-5.domain.ru
https://login4.1domain.ru
http://login.domain.ru
https://domain.ru
https://login99.domain.ru`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}