use strict;
my $str = 'https://login1.domain.ru
https://login2.domain.ru
https://login3.domain.ru
https://login4.domain.ru
https://login4.domain1.ru
https://123.domain.ru
https://login-5.domain.ru
https://login4.1domain.ru
http://login.domain.ru
https://domain.ru
https://login99.domain.ru';
my $regex = qr/^https\:\/\/\S+?\.domain.ru$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}