// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https\:\/\/\S+?\.domain.ru$").unwrap();
let string = "https://login1.domain.ru
https://login2.domain.ru
https://login3.domain.ru
https://login4.domain.ru
https://login4.domain1.ru
https://123.domain.ru
https://login-5.domain.ru
https://login4.1domain.ru
http://login.domain.ru
https://domain.ru
https://login99.domain.ru";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}