package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+`)
var str = `text required name="first_name" label="First Name! $ , ." column="1/2"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}