$re = '/(?=^(?:(?!name).)*Jack.*$).*/m';
$str = 'My name is Jack Brown
My nam is Jack Brown';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);