import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0\\.(?:0[1-9]|[1-9]\\d?)|[1-9]\\d*(?:\\.\\d{1,2})?)(?:e[+-]?\\d+)?$";
final String string = "0.1\n"
+ "0.01\n"
+ "0.10\n"
+ "0.1e34\n"
+ "0.1e+3\n"
+ "0.1E-2\n"
+ "1.00e3\n"
+ "1.00\n"
+ "23.45\n"
+ "2e34\n\n"
+ "invalid\n"
+ "0\n"
+ "0.001\n"
+ "12.234\n"
+ "0e34\n"
+ "-1\n"
+ "0.1f45\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}