const regex = new RegExp('`(?:[\\p{Zs}\\t]*(\\w+)[\\p{Zs}\\t]*)+`', 'gm')
const str = `some description \` match these_words th_is_wor \` or \`THIS_WOR thi_sqw\` a \`word_snake\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}