package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:^|[^\\])(?:\\{2})*)\$0`)
var str = `Hello '$0'. '$0' becomes the World. This shall remain \$0. Extra: \\$0 is World, \$0 is escaped.`
var substitution = "$1World"
fmt.Println(re.ReplaceAllString(str, substitution))
}