const regex = /((?:^|[^\\])(?:\\{2})*)\$0/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:^|[^\\\\])(?:\\\\{2})*)\\$0', 'gm')
const str = `Hello '\$0'. '\$0' becomes the World. This shall remain \\\$0. Extra: \\\\\$0 is World, \\\$0 is escaped.`;
const subst = `$1World`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);