const regex = /.+(?=\s-|\(|\?|\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+(?=\\s-|\\(|\\?|\\*)', 'gm')
const str = `123 - 456
dskfskghfjgn ( 454t3t53 )
2343543534 ? 454354354
the test * 346345436t3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}