using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\.((((c|C)(c|pp|xx|\+\+)?$)|((h|H)h?(pp|xx|\+\+)?$))|(ino|pde|proto|cu))$";
string input = @"./test/known_fail/addition.c
./test/known_fail/addition.C
./test/known_fail/addition.cpp
./test/known_fail/addition.cc
./test/known_fail/addition.c++
./test/known_fail/addition.cxx
./test/known_fail/addition.ino
./test/known_fail/addition.pde
test/known_fail/addition.proto
test/known_pass/addition.proto
./test/known_fail/test.h
./test/known_fail/test.H
./test/known_fail/test.hpp
./test/known_fail/test.hh
./test/known_fail/test.h++
./test/known_fail/test.hxx
./.git/objects/13
./.clang-format
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}